Question

In: Computer Science

Design a network with the following requirements: - 4 LANS separated by a WAN - Utilize...

Design a network with the following requirements:

- 4 LANS separated by a WAN

- Utilize any Class C address; any routing protocol

-Implement the following:

In Router 0,

1. Banner

2. Time-out

3. Block Log in

4. Telnet

In Router 1:

1. Privilege Level 15 for User1

2. Privilege level 3 for User 2

3. SSH

Solutions

Expert Solution

Given scenario is 4 LANS separated by a WAN and using any Class C address and any routing protocol

Here choosing the network 192.168.10.0/24 and subnetting it and also choooosing the RIP version 2 protocol for routing.

Network is designed in the packet tracer

Router confguration:

Interfaces Settings

Router 0

Router0(config)#interface GigabitEthernet0/0

Router0(config-if)#no shutdown

Router0(config-if)#ip address 192.168.10.1 255.255.255.224

Router0(config-if)#exit

Router0(config)#interface Serial0/0/0

Router0(config-if)#no shutdown

Router0(config-if)#clock rate 64000

Router0(config-if)#ip address 192.168.10.129 255.255.255.252

Router0(config-if)#exit

Router0(config)#interface GigabitEthernet0/1

Router0(config-if)#no shutdown

Router0(config-if)#ip address 192.168.10.33 255.255.255.224

Router 1:

Router1(config)#interface GigabitEthernet0/0

Router1(config-if)#no shutdown

Router1(config-if)#ip address 192.168.10.65 255.255.255.224

Router1(config-if)#exit

Router1(config)#interface Serial0/0/0

Router1(config-if)#no shutdown

Router1(config-if)#ip address 192.168.10.130 255.255.255.252

Router1(config-if)#exit

Router1(config)#interface GigabitEthernet0/1

Router1(config-if)#no shutdown

Router1(config-if)#ip address 192.168.10.97 255.255.255.224

Show interface settings

Router 0

Router 1

Configure routing using RIPV2

Router0

Router0(config)#router rip

Router0(config-router)#version 2

Router0(config-router)#network 192.168.10.0

Router0(config-router)#network 192.168.10.32

Router0(config-router)#network 192.168.10.128

Router1

Router1(config)#router rip

Router1(config-router)#version 2

Router1(config-router)#network 192.168.10.64

Router1(config-router)#network 192.168.10.96

Router1(config-router)#network 192.168.10.128

Display routing table

Router 0

Router1

Host configuration

PC0

PC1

PC2

PC3

Check connectivity between the LANs using PING

Ping from PC0 to PC1 ,PC2 and PC3

Implement the given requirements

Router 0

1. Banner

Router0(config)#banner motd "Restricted Device"

Router0(config)#do wr

Router0(config)#exit

Router0#logout

2. Time-out

Router0(config)#line console 0

Router0(config-line)#exec-timeout 5

3. Block Log in

Router0(config)#login block-for 60 attempts 3 within 5

For blocking login for 60 minutes when attempts 3 invalid login within 5 minutes.

4. Telnet

Set enable password and telnet password

Router0(config)#enable password cisco123

Router0(config)#line vty 0 4

Router0(config-line)#password cisco

Router0(config-line)#login

Router0(config-line)#

Check telnet access from PC0

Check telnet access from PC3

Router 1

1. Privilege Level 15 for User1

Router1(config)#username User1 privilege 15 password cisco

2. Privilege level 3 for User 2

Router1(config)#username User2 privilege 3 password cisco123

3. SSH

Router1(config)#ip domain name cisco

Router1(config)#line vty 0 4

Router1(config-line)#login local

Router1(config-line)#transport input ssh

Router1(config-line)#exit

Router1(config)#crypto key generate rsa

The name for the keys will be: Router1.cisco

Choose the size of the key modulus in the range of 360 to 2048 for your

General Purpose Keys. Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

Router1(config)#

Check SSH access from PC 3

Check SSH access from PC 2

Check SSH access from PC 0


Related Solutions

1.       Design a network of 2 LANs in Router1 and 1 LAN in Router2. Routers are separated...
1.       Design a network of 2 LANs in Router1 and 1 LAN in Router2. Routers are separated by a serial connection. 2.       Use any Class 3 Major Network address and subnet accordingly. 3.       For design purpose, use 3 end devices in each LAN. Assign the last IP address in the last PC. 4.       Utilize any routing protocol. 5.       Create 2 users in router 1. User 1 – use normal password User 2- use encrypted password Both – min length of password should be 6
PROJECT 4 : DESIGN A HYDRAULIC MOBILE CRANE REQUIREMENTS: •Design the system to carry load of...
PROJECT 4 : DESIGN A HYDRAULIC MOBILE CRANE REQUIREMENTS: •Design the system to carry load of up to 5000 lb •Use a hydraulic winch(rotary actuator)to move the pulleys up and down •Use fail-safe measures to support positive loads and run-away issues •The speed of the crane shouldbe changeable •Use dampeners to prevent vibration and maintain pressure and flow where necessar
Network architecture: Categorize each of the following requirements as core/fundamental, feature, or informational. a. Network must...
Network architecture: Categorize each of the following requirements as core/fundamental, feature, or informational. a. Network must support Fiber Optical interface for all devices on the network b. Network backbone should be upgradable in capacity to 10Gb/s within two years of deployment c. Finance department requires firewall protection to the server. d. Existing network consists of 10BaseT Ethernet and FDDI segments. e. Network personnel would like to be able to bill users for network service. f. Network core may generate or...
Explain the basic differences between circuit switching and packet switching for a wide area network (WAN)....
Explain the basic differences between circuit switching and packet switching for a wide area network (WAN). Short Essay Question
Network Design proposal for a University Problem: Suppose you are asked to design of a network...
Network Design proposal for a University Problem: Suppose you are asked to design of a network infrastructure for a university. The university has 7 departments namely, IT, Finance, HR, Management, Faculty, students and R&D. The university also has an ADSL internet connection which is shared for the different departments. It is required that all the departments should have intercommunication. The R&D department should not have access to the internet. Each of the department contain 50-100 users. Explain your design giving...
Design your home network.  Experiment. Go beyond your home network. Design the network you want. Pick a...
Design your home network.  Experiment. Go beyond your home network. Design the network you want. Pick a networking problem from the internet and design the networking solution. Use lucidchart or vision.
What is a network design document?
What is a network design document?
4. You extracted the following info from WAN Co. regarding its inventory transactions for last three...
4. You extracted the following info from WAN Co. regarding its inventory transactions for last three months. The Co. uses perpetual inventory system. Date Transactions # of Units Per Unit Total Oct 1 Inventory 2,500 $60.00 $150,000 Oct 10 Purchase 7,500 $68.00 $510,000 Oct 28 Sale 3,750 $120.00 $450,000 Oct 30 Sale 1,250 $120.00 $150,000 Nov 5 Sale 500 $120.00 $60,000 Nov10 Purchase 18,000 $70.00 $1,260,000 Nov16 Sale 9,000 $125.00 $1,125,000 Nov28 Sale 8,500 $125.00 $1,062,500 Dec 5 Purchase 15,000...
Using an example explain why network design using IPv6 is simpler compared to IPv4 network design....
Using an example explain why network design using IPv6 is simpler compared to IPv4 network design.
What is called Supertargetting in Heat Exchanger Network Design? How Heat Exchanger Network Design can be...
What is called Supertargetting in Heat Exchanger Network Design? How Heat Exchanger Network Design can be done by paying attention to Supertargetting?
ADVERTISEMENT
ADVERTISEMENT
ADVERTISEMENT