In: Computer Science
Peform realistic simulation and visualization for boosting of a campus network design for interconnection and coding of IoE devices with Cisco packet tracer simulator software. In implementation of the design use the following devices like 1941-router, 2960 and 3560 switch, server, cell tower, MCU, fan, webcam, siren, light, motion detector, motion sensor, smart door etc. a. Construct the IoE devices for campus network design b. perform registration and device conditions for IoE devices c. use blockly or python programming with Micro controller unit to control smart things d. Justify the device conditions used and proposed better solutions to improve standards .
a) I would suggest implementing campus network design Smart
Campus Network Design (SCND), Co-Design this proposed method in
different networking. The devices are used, those devices are Cisco
1941 Router, 2960 switch, 3560 switches, central office.
There are also servers, cell towers and some smart things that are
included in this design.
Devices to be used for implementation:
1. Router(1941) Used to connect campus network to the internet
2. layer two switch (2960) Used to distribute access to the lower layer
3. Layer three switch(3560) Used to perform intra VLAN routing
4. Server To control smart thing registered on it and provide difference server functionalities
5. Central office server Used to connect cellular system to the router
6. MCU Used to interconnect different smart thing
7. Pc Connect to access layer
8. Fan Used to ventilate the campus based on some condition
9. Webcam Control the campus
10. Siren Provide sound for some event in the campus
11. Light Provide light
12. Motion detector Connect to home getaway and provide Detection of motion
13. Smart door Connect to home getaway and provide Function based event
14. Cell tower Provide cellular system coverage for different user
15. Tablet Used to control the campus from outside
16. Old car To detect smoke
17. LCD To display text
18. Motion sensor To sense motion by mouse movement
b) Device Configuration
To implement the campus network design on cisco packer tracer , I used class A IP address that is 10.10.220.0/24 subnet and this subnet divided into eight subnet from this eight subnet, I used four of them and the rest are reserved for future scalability.
• Core Router
Router(config)#hostname corerouter
corerouter(config)#interface g0/0
corerouter(config-if)#ip address 10.10.220.1
255.255.255.224
corerouter(config-if)#no shutdown
corerouter(config)#int g0/1
corerouter(config-if)#ip add 209.165.20.225
255.255.255.224
corerouter(config-if)#no sh
corerouter(config)#ipdhcp excluded-address
209.165.20.225 209.165.20.229
corerouter(config)#ipdhcp pool tell
corerouter(dhcp-config)#network 209.165.20.224
255.255.255.224
corerouter(dhcp-config)#default-router
209.165.20.225
corerouter(dhcp-config)#dns-server 10.10.220.40
Command for checking running configuration
corerouter#show running-config
Building configuration...
Current configuration : 1072 bytes
!
version 15.1
no service timestamps log datetimemsec
no service timestamps debug datetimemsec
service password-encryption
!
hostname corerouter
!
enable secret 5
$1$mERr$Me19uJMtOy6/CjrWm.7sd1
!
ipdhcp excluded-address 209.165.20.225
209.165.20.229
!
ipdhcp pool tell
network 209.165.20.224 255.255.255.224
default-router 209.165.20.225
dns-server 10.10.220.35
!
!
!
ipcef
no ipv6 cef
!
license udipid CISCO1941/K9 sn
FTX1524UANM
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 10.10.220.1 255.255.255.224
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 209.165.20.225 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 10.10.220.0 255.255.255.0 10.10.220.2
ip route 10.10.220.0 255.255.255.224 10.10.220.2
!
ip flow-export version 9
!
no cdp run
!
!
line con 0
password 7 08224D43190C16
!
line aux 0
!
line vty 0 4
password 7 08224D43190C16
login
line vty 5 15
password 7 08224D43190C16
login
!
end
Switch(config)#hostname multlayerswitch
multlayerswitch(config)#vlan 10
multlayerswitch(config-vlan)#name serverfarm
multlayerswitch(config-vlan)#vlan 20
multlayerswitch(config-vlan)#name admin
multlayerswitch(config-vlan)#vlan 30
multlayerswitch(config-vlan)#name
MCUsmartthing
multlayerswitch(config-vlan)#vlan 40
multlayerswitch(config-vlan)#name
gatewaysmartthing
multlayerswitch(config-vlan)#
multlayerswitch3(config)#ipdhcp excludedaddress 10.10.220.96
10.10.220.99
multlayerswitch3(config)#ipdhcp pool
mcusmartthing
multlayerswitch3(dhcp-config)#network
10.10.220.96 255.255.255.224
multlayerswitch3(dhcp-config)#default-router
10.10.220.97
multlayerswitch3(dhcp-config)#dns-server
10.10.220.40
multlayerswitch3(config)#ipdhcp excludedaddress 10.10.220.128
10.10.220.130
multlayerswitch3(config)#ipdhcp pool
getwaysmartthing
multlayerswitch3(dhcp-config)#network
10.10.220.128 255.255.255.224
multlayerswitch3(dhcp-config)#default-router
10.10.220.129
multlayerswitch3(dhcp-config)#dns-server
10.10.220.40
multlayerswitch#show running-config
Building configuration...
Current configuration : 2742 bytes
!
version 12.2
no service timestamps log datetimemsec
no service timestamps debug datetimemsec
no service password-encryption
!
hostname multlayerswitch
!
ipdhcp excluded-address 10.10.220.64
10.10.220.68
ipdhcp excluded-address 10.10.220.96
10.10.220.100
ipdhcp excluded-address 10.10.220.128
10.10.220.130
ipdhcp excluded-address 10.10.220.33
10.10.220.35
!
ipdhcp pool serverroom
network 10.10.220.32 255.255.255.224
default-router 10.10.220.33
dns-server 10.10.220.35
ipdhcp pool admin
network 10.10.220.64 255.255.255.224
default-router 10.10.220.65
dns-server 10.10.220.35
ipdhcp pool mcusmartthing
network 10.10.220.96 255.255.255.224
default-router 10.10.220.97
dns-server 10.10.220.35
ipdhcp pool getwaysmartthing
network 10.10.220.128 255.255.255.224
default-router 10.10.220.129
dns-server 10.10.220.35
!
!
ip routing
!
spanning-tree mode pvst
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 00e0.f9c0.0001
ip address 10.10.220.33 255.255.255.224
!
interface Vlan20
mac-address 00e0.f9c0.0002
ip address 10.10.220.65 255.255.255.224
!
interface Vlan30
mac-address 00e0.f9c0.0003
ip address 10.10.220.97 255.255.255.224
!
interface Vlan40
mac-address 00e0.f9c0.0004
ip address 10.10.220.129 255.255.255.224
!
ip classless
ip route 209.165.20.224 255.255.255.224
10.10.220.1
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
c)
Python code for MCU Implementation for controlling smart
things:
from gpio import *
from time import *
def main():
pinMode(0, OUT)
pinMode(1, OUT)
pinMode(2, OUT)
pinMode(3, IN)
pinMode(4, OUT)
print("BLINKING")
while True:
customWrite(1, "wel come");
digitalWrite(2, LOW);
customWrite(0, 0);
customWrite(4, 0);
if (digitalRead(3)):
customWrite(3, 0);
customWrite(0, 1);
customWrite(1,
"Warning");
digitalWrite(2, HIGH);
customWrite(4, 1);
print("ALERT")
delay(1000)
if __name__ == "__main__":
main()
d) To improve the campus network service, with the help of internet of thing device with classically network device, realistic simulation and visualization for boosting of a campus network designed. Each smart device registered to IOT server or home getaway and controlled by legitimate user.This design also include Hierarchical Network Design as a hierarchical design is used to group devices into multiple layers. All implementation of Microcontroller unit (MCU) is used to interconnect different IOE device and control them by coding.To design the campus network design Cisco packet tracer simulator software has been used.
Comment down below for any queries. Rate a thumbs up if you like it.
Thank you.